Help with simpegEM1D

Hello,
thanks to the deveolpers, this library has been very helpful,

I’m not sure if this is the right place to ask this:
Has anybody used simpegEM1D? This is a package for simulation and inversion of electromagnetic surveys, which uses SimPEG.
I’m trying to run some examples, but so far i can’t even import simpegEM1D. I reinstalled both to make sure i have the current versions: SimPEG 14.3 and simpegEM1D 0.0.18a0.

This is what happens when i try to import simpegEM1D:

import simpegEM1D
Traceback (most recent call last):

** File “”, line 1, in **
** import simpegEM1D**

** File “C:\Users\Usuario\Anaconda3\lib\site-packages\simpegEM1D_init_.py”, line 1, in **
** from .EM1D import EM1D**

** File “C:\Users\Usuario\Anaconda3\lib\site-packages\simpegEM1D\EM1D.py”, line 1, in **
** from SimPEG import Maps, Utils, Problem, Props**

ImportError: cannot import name ‘Maps’ from ‘SimPEG’ (C:\Users\Usuario\Anaconda3\lib\site-packages\SimPEG_init_.py)

Has anybody had used simpegEM1D recently? I think the problem may be different versions of SimPEG uses uppercases or lowercases for some folders.

That’s right. Since the SimPEG 0.14 release, they use a new naming convention and changed some namings. Problem → simulation etc. I believe it’s an improvement, but then you run into problems with simpegem1d.

You could try if it works by installing an earlier version of SimPEG?

Thanks, i tried with an older version of SimPEG (0.13.1).
After that change, the error now was in empymod. So i installed an older version of that too (1.10.6).
Now it works.

1 Like

Great you figured it out, and sorry for the late reply. As @wouterdls mention, a lot changed with SimPEG v0.14, and also with discretize v0.6 and empymod v2.

In the not-so-distant future simpegEM1D will be included directly in SimPEG, which should avoid these kind of problems!